Pagina 1 din 1

oVirt - обновление менеджера

Scris: 19 Oct 2015, 12:57
de barmaleyster
:o Добрый всем день!

Прошло больше года и настала пора обновляться :?

Конфигурация системы за год не изменилась:

CentOS-6.5
oVirt-3.4

Отдельно три гипервизора, отдельно oVirt-manager, отдельно postgres.
В дата-центре три стораджа: Export (NFS), Data Master (GlusterFS), ISO (NFS)


Предыдущая проблема с GlasterFS
viewtopic.php?f=18&t=5588
решилась при помощи бубна. Если кому интересно, могу поделиться заклинанием.
;)

Теперь друга проблема. Проблема с обновлением версий с CentOS-6.5 на SentOS-.6.7 и oVirt-3.4.0 на oVirt-3.4.4 только на менеджере

Собственно сама процедура обновления прошла без сучка-без задоринки. Но! Когда открыл WEB-панель, и.....
ужас и паника!
:o :o :o :o

В статусе виртуалок знаки вопроса, все ноды "Non Responsive State", все стораджи в дауне, ну и сам DC там же.

Но не смотря на это, вся система работает нормально! Все виртуалки и ноды, тьфу-тьфу-тьфу доступны и работают.

Хорошо. Гугл мне в помощь.
Нахожу идентичную ситуацию после обновления менеджера, правда для RH:
https://access.redhat.com/discussions/1326793

Произвожу необходимые действия - не помогает. В логе следующее:

Cod: Selectaţi tot

f467a9e5, vds=Host[node-14,1e8baa86-b90f-48a2-af9f-f09af467a9e5]) execution failed. Exception: VDSNetworkException: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
2015-10-19 12:34:19,634 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand] (DefaultQuartzScheduler_Worker-89) Command GetCapabilitiesVDSCommand(HostName = node-13, HostId = 6e9ab07e-f7d6-4a8f-8efd-227d3264bae9, vds=Host[node-13,6e9ab07e-f7d6-4a8f-8efd-227d3264bae9]) execution failed. Exception: VDSNetworkException: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
2015-10-19 12:34:21,644 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand] (DefaultQuartzScheduler_Worker-93) Command GetCapabilitiesVDSCommand(HostName = node-15, HostId = 9192228b-4fb2-4042-be0f-d45b8206a2ca, vds=Host[node-15,9192228b-4fb2-4042-be0f-d45b8206a2ca]) execution failed. Exception: VDSNetworkException: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
2015-10-19 12:34:22,629 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.GetCapabilitiesVDSCommand] (DefaultQuartzScheduler_Worker-95) Command GetCapabilitiesVDSCommand(HostName = node-14, HostId = 1e8baa86-b90f-48a2-af9f-f09af467a9e5, vds=Host[node-14,1e8baa86-b90f-48a2-af9f-f09af467a9e5]) execution failed. Exception: VDSNetworkException: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target


Попытки отката ни к чему не привели.
Хорошо. Откат откатом, но мне никто не мешает снести всё на менеджере и установить заново. Но! При установке ovirt-engine через yum подтягиваются только обновлённые пакеты :( и ситуация не меняется

Из всего этого я понял, что менеджер не может подключиться ни к одной из нод из-за какой-то не стыковки по SSL (или ошибаюсь?).

Хорошо. Теперь пытаюсь обновить хотя-бы одну ноду с версии CentOS-6.5 на CentOS-6.7
Не тут-то было. Процедура обновления матерится не неудовлетворение зависимостей пакетов vdsm и qemu-kvm:

Cod: Selectaţi tot

Error: Package: vdsm-gluster-4.14.17-0.el6.noarch (ovirt-3.4-stable)
           Requires: vdsm = 4.14.17-0.el6
           Removing: vdsm-4.14.11.2-0.el6.x86_64 (@ovirt-3.4-stable)
               vdsm = 4.14.11.2-0.el6
           Updated By: vdsm-4.16.20-1.git3a90f62.el6.x86_64 (epel)
               vdsm = 4.16.20-1.git3a90f62.el6
           Available: vdsm-4.14.6-0.el6.i686 (ovirt-3.4-stable)
               vdsm = 4.14.6-0.el6
           Available: vdsm-4.14.8.1-0.el6.i686 (ovirt-3.4-stable)
               vdsm = 4.14.8.1-0.el6
           Available: vdsm-4.14.9-0.el6.x86_64 (ovirt-3.4-stable)
               vdsm = 4.14.9-0.el6
           Available: vdsm-4.14.11-0.el6.i686 (ovirt-3.4-stable)
               vdsm = 4.14.11-0.el6
           Available: vdsm-4.14.17-0.el6.x86_64 (ovirt-3.4-stable)
               vdsm = 4.14.17-0.el6
Error: Package: vdsm-4.16.20-1.git3a90f62.el6.x86_64 (epel)
           Requires: qemu-kvm >= 2:0.12.1.2-2.422
           Installed: 2:qemu-kvm-rhev-0.12.1.2-2.415.el6_5.14.x86_64 (@ovirt-3.4-stable)
               qemu-kvm = 2:0.12.1.2-2.415.el6_5.14
           Available: 2:qemu-kvm-0.12.1.2-2.479.el6.x86_64 (base)
               qemu-kvm = 2:0.12.1.2-2.479.el6
           Available: 2:qemu-kvm-0.12.1.2-2.479.el6_7.1.x86_64 (updates)
               qemu-kvm = 2:0.12.1.2-2.479.el6_7.1
Error: Package: vdsm-4.16.20-1.git3a90f62.el6.x86_64 (epel)
           Requires: qemu-img >= 2:0.12.1.2-2.422
           Installed: 2:qemu-img-rhev-0.12.1.2-2.415.el6_5.14.x86_64 (@ovirt-3.4-stable)
               qemu-img = 2:0.12.1.2-2.415.el6_5.14
           Available: 2:qemu-img-0.12.1.2-2.479.el6.x86_64 (base)
               qemu-img = 2:0.12.1.2-2.479.el6
           Available: 2:qemu-img-0.12.1.2-2.479.el6_7.1.x86_64 (updates)
               qemu-img = 2:0.12.1.2-2.479.el6_7.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Конечно, можно попробовать побороть эту не стыковку, но терзают сомнения, что всё может заработать прежним нормальным образом


Прошу помощи, кто прошёл через это обновление или ещё какие мыли по этому поводу

P.S.

При обновлении менеджера на v3.5 ситуация не меняется.


С уважением...

Re: oVirt - обновление менеджера

Scris: 28 Dec 2015, 00:49
de jekader
проблема ещё актуальна? Каким образом обновляешься - при помощи engine-setup?